Author Topic: Simple Cgminer Remote Monitoring Script - now with alerts  (Read 42070 times)

Offline grobbes

  • Newbie
  • *
  • Posts: 17
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #45 on: June 28, 2013, 03:08:03 AM »
p4xil, thanks again for providing this. any plans on adding control functionality to the miners via the api?

Offline svennand

  • Newbie
  • *
  • Posts: 4
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #46 on: June 28, 2013, 11:11:09 AM »
I have the port forwarded on my router and the exception in the firewall on my mining rig but it get all zeros in the miner status. I then get the following error on the actual miner table
Code: [Select]
Invalid argument supplied for foreach() in /home/michen47/heartofalion28.com/monitoring/index.php on line 151
My hosting is thru Dreamhost.

Any help would be much appreciated


EDIT::::if i use the api-network command i can connect...how can i find the IP for my webserver?

EDIT EDIT:::::got it working...had to purchase a unique IP for my site. love the script!

I have the same problem with my miners registering offline, even tough i have open all the ports and so on.
tried api-network command but not quite sure how to formulate it, cgminer only shutdown when i input api-network.
Could you post the entire string of commands you use for api part in cgminer script?

are you using a conf file? if so, you need to set it to

"api-network" : true,

if using a bat file, just add

--api-network

should do the trick
Found out why cgminer crashed, had hit space someplace else on the command line makin cgminer throw a fit regardless of api stuff.

so the bat should say this:  api-port 4002 --api-network

It still doesnt work. miner is stated offline. done everything as the guide said to do. hmm
port forwarded 4002/4002 to 192.168.0.2 (disabled firewall to be sure that that would be the problem), used my external wan adress as miner ip.
created account at bluehost.com and added both cron settings and edited my minerscript adress på my bluehost webside ip.

Any ideas?, been banging head in desk for three days now, really want this to work :P

Offline grobbes

  • Newbie
  • *
  • Posts: 17
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #47 on: June 28, 2013, 05:05:58 PM »
I have the port forwarded on my router and the exception in the firewall on my mining rig but it get all zeros in the miner status. I then get the following error on the actual miner table
Code: [Select]
Invalid argument supplied for foreach() in /home/michen47/heartofalion28.com/monitoring/index.php on line 151
My hosting is thru Dreamhost.

Any help would be much appreciated


EDIT::::if i use the api-network command i can connect...how can i find the IP for my webserver?

EDIT EDIT:::::got it working...had to purchase a unique IP for my site. love the script!

I have the same problem with my miners registering offline, even tough i have open all the ports and so on.
tried api-network command but not quite sure how to formulate it, cgminer only shutdown when i input api-network.
Could you post the entire string of commands you use for api part in cgminer script?

are you using a conf file? if so, you need to set it to

"api-network" : true,

if using a bat file, just add

--api-network

should do the trick
Found out why cgminer crashed, had hit space someplace else on the command line makin cgminer throw a fit regardless of api stuff.

so the bat should say this:  api-port 4002 --api-network

It still doesnt work. miner is stated offline. done everything as the guide said to do. hmm
port forwarded 4002/4002 to 192.168.0.2 (disabled firewall to be sure that that would be the problem), used my external wan adress as miner ip.
created account at bluehost.com and added both cron settings and edited my minerscript adress på my bluehost webside ip.

Any ideas?, been banging head in desk for three days now, really want this to work :P

oh it's hosted offsite? in that case, it should be this:

--api-listen --api-port 4002 --api-allow (your website's IP address)

obviously don't put the brackets around the IP address :)

Offline svennand

  • Newbie
  • *
  • Posts: 4
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #48 on: June 28, 2013, 06:34:30 PM »
I have the port forwarded on my router and the exception in the firewall on my mining rig but it get all zeros in the miner status. I then get the following error on the actual miner table
Code: [Select]
Invalid argument supplied for foreach() in /home/michen47/heartofalion28.com/monitoring/index.php on line 151
My hosting is thru Dreamhost.

Any help would be much appreciated


EDIT::::if i use the api-network command i can connect...how can i find the IP for my webserver?

EDIT EDIT:::::got it working...had to purchase a unique IP for my site. love the script!

I have the same problem with my miners registering offline, even tough i have open all the ports and so on.
tried api-network command but not quite sure how to formulate it, cgminer only shutdown when i input api-network.
Could you post the entire string of commands you use for api part in cgminer script?

are you using a conf file? if so, you need to set it to

"api-network" : true,

if using a bat file, just add

--api-network

should do the trick
Found out why cgminer crashed, had hit space someplace else on the command line makin cgminer throw a fit regardless of api stuff.

so the bat should say this:  api-port 4002 --api-network

It still doesnt work. miner is stated offline. done everything as the guide said to do. hmm
port forwarded 4002/4002 to 192.168.0.2 (disabled firewall to be sure that that would be the problem), used my external wan adress as miner ip.
created account at bluehost.com and added both cron settings and edited my minerscript adress på my bluehost webside ip.

Any ideas?, been banging head in desk for three days now, really want this to work :P

oh it's hosted offsite? in that case, it should be this:

--api-listen --api-port 4002 --api-allow (your website's IP address)

obviously don't put the brackets around the IP address :)

that was what i originally did, and didnt work. tried both url and ipadress=P damnit ::)

Offline grobbes

  • Newbie
  • *
  • Posts: 17
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #49 on: June 28, 2013, 07:33:33 PM »
Have you tried looking at your server logs to see any errors? Try manually running the cron command and see what error it produces.

You can PM me your functions.inc.php and bat file, replacing IP addresses with just markers like MINER IP ADDRESS and SERVER IP ADDRESS and I can take a look.

Offline svennand

  • Newbie
  • *
  • Posts: 4
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #50 on: June 28, 2013, 08:13:45 PM »
pmed you.
Checked the log file in monitoring:

It spams this every time it refreshes:
[28-Jun-2013 14:08:53] PHP Warning:  socket_connect() [<a href='function.socket-connect'>function.socket-connect[/url]]: unable to connect [115]: Operation now in progress in /home1/featherp/public_html/monitoring/functions.inc.php on line 98
[28-Jun-2013 14:08:53] PHP Warning:  Invalid argument supplied for foreach() in /home1/featherp/public_html/monitoring/index.php on line 151

Are there something wrong with my ports?
Used web services to check the 4002 port and they all state it to be open.
The port is forwarded to my local ip adress of the rig with the cgminer running

EDIT:
GOT IT FIXED, note to self. do not assume that because your ports are open all the way, your web supplier has the same.
Had to manually contact em and ask them to open socket ports for php
« Last Edit: June 28, 2013, 08:26:06 PM by svennand »

Offline grobbes

  • Newbie
  • *
  • Posts: 17
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #51 on: June 28, 2013, 08:30:49 PM »
pmed you.
Checked the log file in monitoring:

It spams this every time it refreshes:
[28-Jun-2013 14:08:53] PHP Warning:  socket_connect() [<a href='function.socket-connect'>function.socket-connect[/url]]: unable to connect [115]: Operation now in progress in /home1/featherp/public_html/monitoring/functions.inc.php on line 98
[28-Jun-2013 14:08:53] PHP Warning:  Invalid argument supplied for foreach() in /home1/featherp/public_html/monitoring/index.php on line 151

Are there something wrong with my ports?
Used web services to check the 4002 port and they all state it to be open.
The port is forwarded to my local ip adress of the rig with the cgminer running

EDIT:
GOT IT FIXED, note to self. do not assume that because your ports are open all the way, your web supplier has the same.
Had to manually contact em and ask them to open socket ports for php

Excellent! Happing mining my friend :)

Offline pmastery

  • Newbie
  • *
  • Posts: 3
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #52 on: December 08, 2013, 07:55:35 PM »
Hi,

Very nice !! Good job.


Web page show always "OFFLINE" but i am sure a follow the procedure.

Someone help me ?

The port seems to be open correctly.

Many thanks !


Offline compile

  • Newbie
  • *
  • Posts: 4
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #53 on: December 19, 2013, 06:54:43 PM »
Is there a Postfix/Sendmail for Windows that works with this?

I don't know which to get.

Offline biggen

  • Full Member
  • ***
  • Posts: 397
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #54 on: December 23, 2013, 05:32:33 PM »
I got this installed today.  Very cool!  I have noticed that the accepted and rejected shares is incorrect.  It is only showing like 4 or 5 accepted share for each GPU while cgminer is showing several thousand accepted shares for each GPU.  I wonder if something changed in CGminer since this script was built that broker something.  I'm using 3.7.2 btw.

Offline p4xil

  • Jr. Member
  • **
  • Posts: 130
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #55 on: December 29, 2013, 09:53:43 AM »
It is not broken. I think since version 3.5, accepted and rejected shares get multiplied by pool difficulty. That is why the number is different. In the monitor it is the same number only it is not multiplied.


Yesterday I've added ASC and PGA support to the script and now you can disable/enable Pool and username.

Offline p4xil

  • Jr. Member
  • **
  • Posts: 130
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #56 on: January 02, 2014, 01:54:44 PM »
v2.2.1 Fixed Some Bugs

Offline make888

  • Newbie
  • *
  • Posts: 2
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #57 on: January 04, 2014, 09:51:28 AM »
all are ok,but i don't know how to config email,pls help

Offline p4xil

  • Jr. Member
  • **
  • Posts: 130
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #58 on: January 04, 2014, 01:59:27 PM »
do you have windows or linux system?

Offline psYGottesHand

  • Newbie
  • *
  • Posts: 2
Re: Simple Cgminer Remote Monitoring Script - now with alerts
« Reply #59 on: January 05, 2014, 01:56:39 AM »
Hi p4xil,

i´ve got a little problem here, i use 4 rigs over a private provider and the ip changes every 24h.

so wenn i´m setting up the functions.inc.php it works (exept the error messages for socket_connect() unable to connect [115] based on closed ports on the side of my hoster)
i can see when my rigs are online, if they are offline the errorcode comes up, but never mind.

the whole system works but at the point of auto reconnect and ip change all miners showed as offline.
that´s a true information at this point, wrong ip´s set up in the functions.inc.

have you any idea to not set up all ip´s manually every 24h?
like a dynamic named server adress or whatever...

btw a very nice work!

and thanks for the service :D