Author Topic: Litecoin Core 0.10.x - sync problem on x86 [EXCEPTION: St9bad_alloc]  (Read 950 times)

Offline 3eroCold

  • Newbie
  • *
  • Posts: 3
  • Be smart, be secure.
Quote from: debug.log
2016-02-03 22:04:29 UpdateTip: new best=75b6899c312985c1f769ffab3f6d99d0666bf828f86d39140402691b0591f5bb  height=270672  log2_work=52.814618  tx=733183  date=2012-12-30 16:19:02 progress=0.046874  cache=171267
2016-02-03 22:05:49

************************
EXCEPTION: St9bad_alloc      
std::bad_alloc       
G:\Soft\Litecoin\litecoin-qt.exe in ProcessMessages()       

2016-02-03 22:05:49 ProcessMessage(block, 223 bytes) FAILED peer=5
2016-02-03 22:06:05 UpdateTip: new best=b77191e1d5c3c4d80637b0b6b2b9eec3aafeb3d105c943cdfca5b2766604f9f2  height=270673  log2_work=52.814642  tx=733184  date=2012-12-30 16:19:09 progress=0.046874  cache=78603
2016-02-03 22:06:05 UpdateTip: new best=139056024b0cfbe1440a9b9072dd6fc14d3e99e58180e0eecae2e000c2b5ab11  height=270674  log2_work=52.814666  tx=733185  date=2012-12-30 16:23:33 progress=0.046874  cache=78604
2016-02-03 22:06:05 UpdateTip: new best=2fc2a2a0143e3e6462d5496b7f08107c0063539cf12b34ff903040fe35ba1c9b  height=270675  log2_work=52.81469  tx=733186  date=2012-12-30 16:25:31 progress=0.046874  cache=78605
2016-02-03 22:06:05 UpdateTip: new best=ffac338c91cbe504c22290c871d4d8ff89b23cd89e547cca5152002b58262651  height=270676  log2_work=52.814714  tx=733187  date=2012-12-30 16:27:46 progress=0.046875  cache=78606
2016-02-03 22:06:05 ERROR: ConnectBlock() : inputs missing/spent
2016-02-03 22:06:05 Misbehaving: 50.147.82.216:9333 (0 -> 100) BAN THRESHOLD EXCEEDED

Each time I got St9bad_alloc , I already tried many times with old files, with clear version (without old files).
After error it stop sync.
Each time (after restart) it starts to index/sync from beginning of time Litecoin history.
Didn't find something useful in google, best try was -dbcache=2000 from thread on bitcointalk, but it didn't help.

This happens after row of my mistakes:
1. was not enough space on local drive where was litecoin.
2. after restart it start to sync and I got some error then I without thinking twice reinstall Litecoin Core above.

Now I have enough space and try on ssd and hdd. With old files and on blank space - same result.

Windows 7  Intel Quad Core x86 8Gb, also tried on Windows Vista x86 Core 2 Duo 3Gb.

Currently problem reproduced:
Litecoin Core 0.10.4.0 x86
Litecoin Core 0.10.3.0 x86 (I assume rc1)
Litecoin Core 0.10.2.2 x86

Success on Windows 7 x64 Core 2 Duo 4Gb, Litecoin Core 0.10.4.0 x64 sync successful, It took no more than 3-4 hours.
Success on Windows 7 x86 Quad Core 8Gb, Litecoin Core 0.8.7.5 x86 sync successful, took 7.5 hours.


However, problem persists on Litecoin Core 0.10.x 32bit (x86).
« Last Edit: February 06, 2016, 04:15:20 PM by 3eroCold »

Offline thrasher

  • Litecoin Dev Team
  • Jr. Member
  • **
  • Posts: 28
Re: Litecoin Core 0.10.x - sync problem on x86 [EXCEPTION: St9bad_alloc]
« Reply #1 on: February 08, 2016, 01:01:07 AM »
The bad_alloc exception is thrown when a new variable was attempted to be created, but there wasn't enough available storage (in this case its system memory).

Some things you could try are setting your dbcache value higher, increasing your systems page file size, observing the amount of free memory on your system using task manager -> Performance -> Memory to find out what process is consuming it all.

Offline 3eroCold

  • Newbie
  • *
  • Posts: 3
  • Be smart, be secure.
Re: Litecoin Core 0.10.x - sync problem on x86 [EXCEPTION: St9bad_alloc]
« Reply #2 on: February 12, 2016, 02:54:00 AM »
Thanks for answer.

My first assumption was that I install additional memory (4Gb→8Gb) few month ago, but when it fall down on another pc...
I think in Litecoin Core is some kind of bug that must be fixed. Because it didn't happens before.

I sync blockchain on x64 then move it to my x86. Works fine.