Author Topic: How to compile latest release? (0.10.2.2)  (Read 1970 times)

Offline prelude

  • Jr. Member
  • **
  • Posts: 69
How to compile latest release? (0.10.2.2)
« on: June 20, 2015, 05:44:32 PM »
Seems makefile.unix is no longer a thing, how do we compile the latest version in ubuntu?

Code: [Select]
cd
git clone https://github.com/litecoin-project/litecoin.git
cd litecoin/src
make -f makefile.unix USE_UPNP=-

Results in:

make: *** No rule to make target `makefile.unix'.  Stop.


Using ls, I've realized that makefile.unix no longer exists. There is Makefile.am, Makefile.qt.include, Makefile.qttest.include, and Makefile.test.include but I can't figure out how to use them.

Please help!

Offline thrasher

  • Litecoin Dev Team
  • Jr. Member
  • **
  • Posts: 28
Re: How to compile latest release? (0.10.2.2)
« Reply #1 on: June 21, 2015, 12:33:36 AM »
Litecoin v0.10.2.2 now uses autoconf and the build instructions can be found here:

https://github.com/litecoin-project/litecoin/blob/master-0.10/doc/build-unix.md

Offline prelude

  • Jr. Member
  • **
  • Posts: 69
Re: How to compile latest release? (0.10.2.2)
« Reply #2 on: June 21, 2015, 01:52:01 AM »
Thank you!

Offline prelude

  • Jr. Member
  • **
  • Posts: 69
Re: How to compile latest release? (0.10.2.2)
« Reply #3 on: June 21, 2015, 01:58:32 AM »
Hmm, ran into an issue, following this:

Code: [Select]
./autogen.sh
./configure
make
make install # optional

Steps 1 and 2 went fine, but the "make" command doesn't work:

Code: [Select]
make: *** No targets specified and no makefile found.  Stop.

Edit: Hadn't noticed, but got an error when running ./configure :

Code: [Select]
configure: error: Found Berkeley DB other than 4.8, required for portable wallets (--with-incompatible-bdb to ignore or --disable-wallet to disable wallet functionality)
« Last Edit: June 21, 2015, 02:40:19 AM by prelude »

Offline thrasher

  • Litecoin Dev Team
  • Jr. Member
  • **
  • Posts: 28
Re: How to compile latest release? (0.10.2.2)
« Reply #4 on: June 21, 2015, 06:53:29 AM »
May I ask what distro you are using? Some distros like Ubuntu and Debian have only newer versions available of BDB which are not backwards compatible and can cause wallet compatibility issues. To resolve the issue, you'll need to obtain the libdb4.8-dev and libdb4.8++-dev packages. Depending on which one you have, each disto requires different steps - If you use either of the mentioned distros you can find these steps under 'Dependency Build Instructions: Ubuntu & Debian' in the build guide.

Offline defaced

  • Jr. Member
  • **
  • Posts: 40
  • Franko is Freedom
    • Franko
Re: How to compile latest release? (0.10.2.2)
« Reply #5 on: June 24, 2015, 02:44:29 AM »
I recommend using gitian, its a little less fail proof.

But if you just want to do the method you are using now. You can add the following flags at config time.

Code: [Select]
./autogen
./configure [b]--disable-tests --with-incompatible-bdb[/b]
make

Offline diegocalavera

  • Newbie
  • *
  • Posts: 1
Re: How to compile latest release? (0.10.2.2)
« Reply #6 on: December 06, 2015, 05:53:31 PM »
Hello there,

can someone write me some step by step tutorial how to compile this Litecoin Core 0.10.2.2 in Ubuntu 15.10 willy werewolf?

I have installed all necessary dependency packages since i am already running Bitcoin and Peerunity wallets in linux. But i can't get this one working. I tried package from Github and official tar.gz package too.

I would be grateful for any help... thanks for reply.