Author Topic: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS  (Read 101403 times)

Offline liquidsnake1989

  • Jr. Member
  • **
  • Posts: 38
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #15 on: December 20, 2013, 10:32:12 AM »
Good to see that this topic gets the attention.

In the meantime I brought my Vapor-X's back to the store and bought two MSI 280X's since those were the only ones in stock atm. They are running about 710-720 Kh/s at the moment, I haven't had much time yet to finetune it.

But yeah there's probably some weird solution lying around somewhere but I personally didn't have the time and simply did not feel like HOURS and HOURS of tryal & error.

Message to the Vapor-X owners: I'd say keep posting your findings here, maybe someone will eventually find a solution so all can benefit. Like I said above I dont have the Vapor-X's anymore so Im affraid I can be of little assistance from now on. But I'll keep an eye out to this topic.

Offline liquidsnake1989

  • Jr. Member
  • **
  • Posts: 38
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #16 on: December 21, 2013, 04:10:43 PM »
bump

Offline wobbzz

  • Newbie
  • *
  • Posts: 14
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #17 on: December 21, 2013, 09:49:25 PM »
OP, can you try this?

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

I'm using these settings on a sapphire 280x vapor-x on linux and am obtaining 740-750Kh/s on bios version 015.040.xxxxxx.

I have some new cards on the way that will likely have your bios version so I'd like to know if I need to cancel that order :P Thanks :)

Offline Phlego

  • Jr. Member
  • **
  • Posts: 81
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #18 on: December 21, 2013, 10:10:07 PM »
OP, can you try this?

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

I'm using these settings on a sapphire 280x vapor-x on linux and am obtaining 740-750Kh/s on bios version 015.040.xxxxxx.

I have some new cards on the way that will likely have your bios version so I'd like to know if I need to cancel that order :P Thanks :)

Not sure but I think OPs cards just overheated. I have exactly the same cards and they run just peachy @ 735, stock out of the box. Been running for days now.

Offline wobbzz

  • Newbie
  • *
  • Posts: 14
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #19 on: December 21, 2013, 11:03:37 PM »
OP, can you try this?

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

I'm using these settings on a sapphire 280x vapor-x on linux and am obtaining 740-750Kh/s on bios version 015.040.xxxxxx.

I have some new cards on the way that will likely have your bios version so I'd like to know if I need to cancel that order :P Thanks :)

Not sure but I think OPs cards just overheated. I have exactly the same cards and they run just peachy @ 735, stock out of the box. Been running for days now.

Same firmware as well Phlego? Also, what operating temps are you experiencing?

Offline alvino

  • Newbie
  • *
  • Posts: 2
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #20 on: December 24, 2013, 04:24:30 AM »
pretty sure its bios .041 like OP said anything prior to that seems fine.

Offline FP_PF

  • Newbie
  • *
  • Posts: 18
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #21 on: December 24, 2013, 05:17:36 AM »
I'm happy for you.  Honestly. 
But, neglecting the "bits & bytes" aspects, tell me... What's your Break-even analysis and ROI say?  Just curious.

Offline slax0r

  • Jr. Member
  • **
  • Posts: 71
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #22 on: December 24, 2013, 05:55:17 AM »
OP, can you try this?

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

I'm using these settings on a sapphire 280x vapor-x on linux and am obtaining 740-750Kh/s on bios version 015.040.xxxxxx.

I have some new cards on the way that will likely have your bios version so I'd like to know if I need to cancel that order :P Thanks :)

I can confirm this, and actually if you'll bump the TC up to 10240, you should see around 760 kH/s stable.  I have also temp-target at 80 overheat at 85 and cutoff at 90.

Offline Suave

  • Jr. Member
  • **
  • Posts: 25
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #23 on: December 24, 2013, 06:03:12 AM »
Having the same issue and I can confirm that keeping the GPUs below 72C solves the problem... That is quite difficult though. I have a 20" box fan blowing full blast and target temp of 70C. Thank you for posting this OP. I've already spent hours searching! Bump this thread. Sticky... Something...

Thanks OP!

Offline wobbzz

  • Newbie
  • *
  • Posts: 14
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #24 on: December 24, 2013, 07:14:21 AM »
OP, can you try this?

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

I'm using these settings on a sapphire 280x vapor-x on linux and am obtaining 740-750Kh/s on bios version 015.040.xxxxxx.

I have some new cards on the way that will likely have your bios version so I'd like to know if I need to cancel that order :P Thanks :)

I can confirm this, and actually if you'll bump the TC up to 10240, you should see around 760 kH/s stable.  I have also temp-target at 80 overheat at 85 and cutoff at 90.

Thanks for the tip slax0r. Can you tell us what bios version you're running please?

Offline cryptomaniac

  • Newbie
  • *
  • Posts: 12
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #25 on: December 24, 2013, 07:16:09 AM »
I may just buy a few R9 290x's myself ::)

Offline Saum

  • Newbie
  • *
  • Posts: 2
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #26 on: December 24, 2013, 09:48:01 AM »
Well, after lurking these forums for a while, I made an account to share my similar plight with the Sapphire 280x Vapor-X throttle issues. I have tried a variety of configs and the best I can achieve is ~710kh/s with 64C. Even this can be a little wacky and drop down to 695kh/s at times. Regardless, I have noticed the same throttle issue on my card after 72C (yes, it is bios version 015.041).

Anyways, as I'm sure most you have figured out by now, we need to find a way to bios flash to 015.039 if there's any chance to start mimicking the results many of the other Sapphire 280x Vapor-X owners have successfully attained. Unfortunately, I have tried various Vapor-X bios versions from http://www.techpowerup.com/vgabios/ to no avail. In a last ditch effort of desperation, I have tried Sapphire Dual-X and even other manufacturer bios' but then I get the above-mentioned issue whereby the CPU won't boot and POST. Essentially, I had to save the backup bios with GPU-Z and then reload it with ATIWINFLASH.

I hope someone can nerd-rage this problem as I'm sure many Sapphire owners are having this problem at the moment. In case anyone cares, this is the config I'm running at the moment.

setx GPU_MAX_ALLOC_PERCENT 100
cgminer.exe --scrypt -o stratum+tcp://ltc.give-me-coins.com:3333 -u FUCK -p SAPPHIRE --thread-concurrency 8192 --lookup-gap 2 --gpu-engine 1027 --gpu-memclock 1500 --gpu-powertune -20 -w 256 -I 13 -g 2

FYI: My rate climbs to ~690kh/s right off the top, but then slowly rises to ~710kh/s over the next 5 minutes...

Offline wobbzz

  • Newbie
  • *
  • Posts: 14
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #27 on: December 24, 2013, 03:11:40 PM »
Well, after lurking these forums for a while, I made an account to share my similar plight with the Sapphire 280x Vapor-X throttle issues. I have tried a variety of configs and the best I can achieve is ~710kh/s with 64C. Even this can be a little wacky and drop down to 695kh/s at times. Regardless, I have noticed the same throttle issue on my card after 72C (yes, it is bios version 015.041).

Anyways, as I'm sure most you have figured out by now, we need to find a way to bios flash to 015.039 if there's any chance to start mimicking the results many of the other Sapphire 280x Vapor-X owners have successfully attained. Unfortunately, I have tried various Vapor-X bios versions from http://www.techpowerup.com/vgabios/ to no avail. In a last ditch effort of desperation, I have tried Sapphire Dual-X and even other manufacturer bios' but then I get the above-mentioned issue whereby the CPU won't boot and POST. Essentially, I had to save the backup bios with GPU-Z and then reload it with ATIWINFLASH.

I hope someone can nerd-rage this problem as I'm sure many Sapphire owners are having this problem at the moment. In case anyone cares, this is the config I'm running at the moment.

setx GPU_MAX_ALLOC_PERCENT 100
cgminer.exe --scrypt -o stratum+tcp://ltc.give-me-coins.com:3333 -u FUCK -p SAPPHIRE --thread-concurrency 8192 --lookup-gap 2 --gpu-engine 1027 --gpu-memclock 1500 --gpu-powertune -20 -w 256 -I 13 -g 2

FYI: My rate climbs to ~690kh/s right off the top, but then slowly rises to ~710kh/s over the next 5 minutes...

Thanks for the feedback and for posting your bios version. Have you tried either of these exact configs?:

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 10240 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

Please test one more thing if you don't mind. While cgminer is running, write the config to a file and then look at the config file to make sure the exact settings you specified via command line are being saved into the file. I've noticed some weird issues where cgminer doesn't always heed the command line arguments that I give it. It just does it's own thing sometimes. To overcome this, I edit the config manually and then start cgminer with no cmd line args.
« Last Edit: December 25, 2013, 01:34:07 AM by wobbzz »

Offline cveks

  • Newbie
  • *
  • Posts: 9
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #28 on: December 24, 2013, 09:56:55 PM »
having same problem.

I can run two at 704-715 khash/s each and no more than that.

It seems that is problem / limitation of Vapor-X bios...

Strange I got older Vapor-X and it runs 740-750 khash/s stable.

Offline Saum

  • Newbie
  • *
  • Posts: 2
Re: HINT/HEADS-UP for Sapphire 280-X Vapor-X miners with LATEST (015.041) BIOS
« Reply #29 on: December 24, 2013, 11:59:59 PM »
Thanks for the feedback and for posting your bios version. Have you tried either of these exact configs?:

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 1080 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

./cgminer --scrypt --lookup-gap 2 --thread-concurrency 8192 -g 2 -I 13 -w 256 --gpu-memclock 1500 --gpu-engine 10240 --gpu-powertune 0 --expiry 1 --scan-time 1 --queue 0 --auto-fan --temp-target 80

Please test one more thing if you don't mind. While cgminer is running, write the config to a file and then look at the config file to make sure the exact settings you specified via command line are being saved into the file. I've noticed some weird issues where cgminer doesn't always heed the command line arguments that I give it. It just does it's own thing sometimes. To overcome this, I edit the config manually and then start cgminer with no cmd line args.

Hey wobbzz,

I have tried the two settings you mentioned to no avail. While I know my best results have been with gpu-engine at 1025, other people have said that 1080 works better for them. All in all, the newer gfx with VRM temp set to 72C causes these cards to throttle and not reach their full potential... it might be worth noting that my roommate picked up some new XFX r9 280x cards and he is having the exact same issue (throttling at 72C and capping out at ~710kh/s) -- in case you're wondering, we have not tried bios flashing the XFX cards...

Anyways, this might be the expertise of someone with a hardware engineering background, or at least a better grasp of bios flashing video cards. [I can bios flash the Vapor-X further if there's reason to believe that there is a working .rom out there.) Unfortunately, I think the extent of my understanding is coming to a close... hopefully someone can help build on what's been tried in this forum...

having same problem.

I can run two at 704-715 khash/s each and no more than that.

It seems that is problem / limitation of Vapor-X bios...

Strange I got older Vapor-X and it runs 740-750 khash/s stable.

I think cveks' post just further confirms our belief about bios versions affecting temperature and potential speed. Perhaps you could do us a favour and install GPU-Z to verify that your new Vapor-X cards are running version 015.041 (reaching ~710kh/s) and your old Vapor-X cards are running version 015.039 (reaching ~750kh/s)

In fact, if you don't mind going one step further, could you rip your .rom file using GPU-Z for version 015.039 (reaching ~750kh/s)? This way I can try to bios flash the new Vapor-X cards to a confirmed old Vapor-X bios and maybe get lucky... Let me know if you want some help figuring out how to rip the .rom file using GPU-Z.

Warmest,
« Last Edit: December 25, 2013, 02:49:17 AM by Saum »